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De la numérisation de caractères à la création de la police

Les étapes ci-dessous valent pour FontLab ou son petit frère TypeTool. Ces deux logiciels se ressemblent étroitement et permettent le même 

type d'opération ; FontLab permet la création automatique des diacritiques (accents) ainsi que le class kerning (regroupement de valeurs 

d'approche d'après les types de lettres)

numériser les lettres à 600 dpi, en niveaux de gris, pour obtenir un fichier tiff

Ouvrir en Photoshop, vérifier que l'on a numérisé bien droit via le menu Affichage>Règles, en tirant un repère depuis la règle; si ce n'est pas le 

cas (comme ci-dessus) mesurer l'angle avec l'outil règle (derrière la pipette) et effectuer une rotation suivant l'angle mesuré. 
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Nettoyer les éléments indésirables à la gomme, éventuellement contraster l'image en brûlant le blanc. Avant :
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Image > Réglages > Niveaux :

Rassembler vers le centre les deux curseurs blanc et noir permet d'augmenter le contraste
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en Illustrator, ouvrir le fichier numérisé (toutes les lettres)
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Cliquer sur l'image numérisée avec l'outil de sélection (flèche noire)

Le bouton "Vectorisation de l'image" devient disponible, ainsi que l'accès à ses paramètres = la petite flèche juste à sa 

droite, sur laquelle on clique pour choisir un des paramètres de vectorisation

On choisit "Esquisse" (CS6, CC) ou "Bandes dessinées" (CS5)
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Il faut vérifier, comparer les paramètres en fonction du résultat. Il est plus commode de les afficher directement en cliquant 

sur l'icone des paramètres :

Voici les réglages de "Bandes dessinées" (CS5) :

Mais il peut être intéressant de personnaliser ces paramètres en affinant le paramètre du tracé ajusté par exemple, ou d'en choisir d'autres 

comme "lettrage" (CS5) qui est très fidèle. Dans tous les cas cocher "Ignorer le blanc".
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ou "Esquisse" (CS6, CC) qui présente un bon rapport qualité / détail. Ces réglages ne créent que les fonds, pas les 

contours

Ci-dessus, il faut bien sûr cocher "avancé" pour avoir toutes les options...  J'ai donc bien vérifié qu'"Ignorer le blanc" est coché.
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Plusieurs affichages du résultat sont possibles 

Qui permettent d'afficher au choix le résultat de la vectorisation, mais également une comparaison avec l'original

Puis l'on crée la vectorisation en cliquant sur Décomposer
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Ensuite il faut dégrouper (Menu Objet >Dissocier)
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En fait deux couches sont superposées, il faut parvenir à sélectionner la première et la supprimer
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Il faudra également le cas échéant supprimer les doubles tracés ; toutes les contreformes (trous dans les lettres) doivent 

être supprimées

Si l'on utilise l'outil de sélection directe (flèche blanche) on peut nettoyer le tracé; les tracés sont souvent doubles et conduisent à un erreur 

dans les logiciels de création de polices.

Avec la flèche blanche, on peut éditer les courbes du tracé pour le corriger. Il est beaucoup plus facile de travailler en mode tracé (menu 

Affichage)
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Dans FontLab ou Typetool, il faut bien sûr créer une police (Fichier > Nouveau), puis régler les préférences (Menu TypeTool 

> Préférences sur Mac, Tools > Options sur Windows)

…pour que les importations et copier/coller prennent bien tout l'emplacement de la lettre (bounding box) - NB. FontLab n'existe qu'en anglais : 

la correspondance est "fit between Ascender and Descender".
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Une fois tout nettoyé, copier-coller la lettre d'Illustrator en Fontlab ou Typetool

La lettre est alors mise en plein milieu de la fenêtre. Pour avoir comme ici l'affichage de la lettre en gris il faut l'activer via le menu Affichage > 

Afficher les calques > Arrière-plan.

Attention, il est également possible de double-cliquer dans la fenêtre de la lettre à importer, puis faire File > Import > Eps à condition d'avoir 
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exporté votre fichier illustrator en EPS.  Mais copier coller la lettre en Typetool ou FontLab va infiniment plus vite!

Après l'importation il faut placer la lettre correctement et la redimensionner avec l'outil free transform : 

Les outils sont disponibles via le menu Affichage > Barres d'outils > Outils
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Entourer la lettre, puis… agrandir ou diminuer (ne pas oublier d'enfoncer la touche majuscule pour garder les proportions) 

en étirant un des 4 coins
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Placement de la lettre

il faut la déplacer manuellement sur la ligne de base (le 0 en pointillé) en laissant déborder un peu les formes courbes et franchement les 

descendantes
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Dans Les deux logiciels cela donne ceci : La capitale sera étirée depuis la baseline jusqu'à rencontrer la ligne C, la 

minuscule va jusqu'à la ligne x

1 : baseline 2 : ligne x (minuscule) 3 : C =  hauteur de capitale 4 : A : ascendante (l, f, t, b, d etc)
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Voici la structure globale des lettres avec les valeurs pour un caractère standard

Donc Ascender, ascendante, hampe = A

Caps height = C

X = hauteur d'X, soit la hauteur d'une lettre minuscule sans hampe ou jambage, un x par exemple...

Ligne pointillée = baseline, ligne courante, de base, sur laquelle repose la lettre

D = descendante, jambage

Ceci vaut pour un caractère à empattements comme ci-dessus mais peut être radicalement différent pour les scriptes.
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Et si la lettre présente une contreforme (espace blanc à l'intérieur, comme dans le p ci-dessus) Elle risque de ne pas 

s'afficher correctement, d'être "opaque"

Aller dans le menu Contour>Tracés et déterminer une direction au caractère, choisir (en gros) direction PS sur Mac et direction TT sur PC. Dans 

d'autres cas il faut Fermer les contours ouverts ou Corriger les connexions...
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Il faut absolument déterminer un espacement de part et d'autre de la lettre, cela peut être fait quand on a placé toutes les 

lettres

Les lignes verticales doivent être un peu séparées de la lettre, ne pas la coller comme ci-dessus. 
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Une action globale doit se faire sur toutes les lettres via Outils > Actions > Métriques > Définir les approches (au moins 30), 

en anglais Tools > Metrics > Set sidebearings
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Il faut maintenant paramétrer les approches entre les caractères 

Ceci a pour but de régulariser ou peaufiner les espaces entre paires de caractères spécifiques. Observez l'approche entre un V et un A 

majuscule, la barre du A doit se rapprocher du V, regardez comme le j va sous le e ci-dessus.

Allez dans le menu Fenêtre > Nouvelle fenêtre de métriques (Window > New Metric window en FontLab) - on va 

commencer par peaufiner les métriques 

Cliquez sur le M pour métriques
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Puis dans le menu Auto
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On va aller chercher du texte spécifique pour créer un maximum d'approches de caractère

http://logofontandlettering.com/kernking.html

copier d'abord la partie 1 des minuscules

http://logofontandlettering.com/kernking.html
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Puis cliquer sur le A/V en haut à gauche, puis coller le texte du site dans la petite fenêtre en bas :
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Reprendre le menu Auto :
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En prenant les réglages ci-dessous :  mais 40 est un exemple, attention - ça peut être bien trop petit...

Et il va créner toutes les paires du texte devant vos yeux ébahis (houba)
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Attention, il y a deux lignes à ce texte, il faut refaire la même opération pour la seconde puis pour la partie 2 de kernking 

(majuscules suivies de minuscules)

Dans le dossier textes j'ai un texte avec les majuscules seules - qui ne sont pas reprises ici : "agencement toutes lettres 

pour la postérité et la gloire (amélioré).doc"

et on recommence !
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Puis il faut peaufiner en prenant du texte en français cette fois-ci et en corrigeant les problèmes résiduels au fur et à 

mesure

1. On clique sur la lettre, dans ce cas-ci le j qui était trop loin du i ; cela fait apparaître une réglette avec le réglage d'approche que TypeTool a 

donné lors de l'approche automatique. 

2. On ramène la réglette et donc la lettre plus près de la lettre qui la précède, ou éventuellement on l'éloigne...
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Vient le temps du test, menu Tools > Quick Test as

Les lettres manquantes doivent bien sûr être corrigées (assez souvent il s'agit d'un problème de contour mal réglé qui peut être corrigé en 

sélectionnant la lettre fautive et en faisant la commande Contour > Correct Open Contour). 
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Bien sûr il est possible d'aumenter la taille...

Où l'on voit qu'il y a encore pas mal de problèmes...
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Grand classique, un problème d'interlignage (espacements entre lignes) trop étroit, peut être réglé depuis la fenêtre Font 

Info (menu Fichier) > Key dimensions

Du coup les dimensions des jambages vont être mises à jour et les interlignages améliorés.
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Ensuite, il faut donner à cette police son nom  - pas le nom du fichier mais le nom qu'elle aura dans les programmes, 

depuis le menu FIchier > Info sur la police :

Cliquer sur "Créer des noms" permet de remplir automatiquement ce qu'il faut, il reste à spécifier la graisse, la chasse et le style (regular ou 

italique par exemple)
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Après le réglage des approches et le test, on crée la police : Fichier > Générer une police, on prend Truetype TT sur pc 

On peut cocher "install the font" et la tester!
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Sous Windows il faut impérativement sélectionner le réglage ci-dessous depuis le bouton Options
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On peut choisir Opentype PS sur mac : 
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Sur Mac on prend le réglage correspondant dans les options



Serge Paulus - sp@serge-paulus.be - 2014De la numérisation de caractères à la création de la police - 38

Il suffit de double-cliquer sur la police pour l'installer, puisque sur Mac elle ne s'installe pas en même temps qu'elle est 

créée :

Sauf bien sûr si vous avez un gestionnaire de polices, comme Font explorer ou FontAgent
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Concernant cette problématique de la création de polices, j'ai créé une formation complète en vidéo chez Video2brain :

https://www.video2brain.com/fr/formation/creer-une-police-de-caracteres-numerique-de-a-a-z

Quelques vidéos y sont en libre accès.

Une vidéo sur la création de glyphes composites en FontLab se trouve également sur YouTube

Cela montre notamment comment générer tous les accents en une fois :

https://www.youtube.com/watch?v=unswvKTi9Rw

https://www.video2brain.com/fr/formation/creer-une-police-de-caracteres-numerique-de-a-a-z
https://www.youtube.com/watch?v=unswvKTi9Rw
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