TypeTool: de la numérisation de caractéres a la création de la police

lien entre le scan (pixel) et I'eps (pour TypeTool) en lllustrator

numériser les lettres a 1200 dpi, en niveaux de gris, pour obtenir un fichier tiff

7.
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Ouvrir en Photoshop, vérifier que I'on a numérisé bien droit via le menu Affichage>Reégles, en tirant un repére depuis la régle; si ce n'est pas le
cas (comme ci-dessus) mesurer |'angle avec |'outil regle (derriere la pipette) et effectuer une rotation suivant I'angle mesuré.

en lllustrator, ouvrir le fichier numérisé (toutes les lettres)

| Scripts | Liens x , .5

g B.tif

[a-g-ala-[.-~

On a pris soin de scanner en 600 dpi, niveaux de gris, et de rogner ce qui est inutile.
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Sélectionner le scan avec I'outil de sélection (fleche noire)

Le bouton "Vectorisation dynamique" devient disponible, ainsi que |'accés a ses paramétres, la petite fleche juste a sa droite, sur laquelle on
clique pour choisir un des parameétres de vectorisation

( Vectorisation dynamique B f Masque \
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On choisit "Bandes dessinées" qui présente un bon rapport qualité/détail et qui ne reprend que les fonds, pas les contours

r
Options de vectorisation
Paramétre prédéfini : | Bandes dessinées [ Vectoriser ]
— Réglages — Paramétres de vectorisation Annuler ‘
Mode : | Noir et blanc # Fonas
| Enregistrer la vectorisation prédéfinie...
Seuil : 200 || Contours
Palette Automatique - Epaisseur maximale du contour i 10 px s J Apergu
Couleurs maximales 26 > Longueur minimale du contour izo px > 0
[} Nouvelle nuance ( Tracé ajusté : ml-S px [j ) Tracés : 113
Atténuation : EE]U-Z 28 [E’ Zone minimale : &14 px B Points d'ancrage - 1318
Couleurs : 2
[2] Rééchantillonnage : E]/»OC px [B Angle d'arrondi : 20
Zones : 57
@ Ignorer le blanc
PPP de I'image : 1200
— Affichage
Trame : | Pas d'image Vecteur : | Résultat de vectorisation

Mais il peut étre intéressant de personnaliser ces paramétres en affinant le paramétre du tracé ajusté par exemple, ou d'en choisir d'autres

comme "lettrage" qui est tres fidele. Dans tous les cas cocher "Ignorer le blanc".

Les deux triangles dans le menu permettent une prévisualisation du résultat

E o —— >V eorererem—re—
. Aucun résultat de vectorisation
g v Résultat de vectorisation

Contours
[\Contours avec vectorisation

|-

Serge Paulus - sam@ihecs.be - sam.ihecs.be

TypeTool: de la numérisation de caracteres a la création de la police - 3



Puis I'on crée la vectorisation en cliquant sur Décomposer

———

Si on n'a pas coché "ignorer le blanc", il faut supprimer les doubles tracés

je conseille de dégrouper (Menu Objet >Dissocier), et d'utiliser I'outil de sélection directe (fleche blanche) pour nettoyer le tracé; les tracés sont
souvent doubles!

avec la fleche blanche, on peut éditer les courbes du tracé pour le corriger. Il est beaucoup plus facile de travailler en mode tracé (menu
affichage)
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Dans Typetool, il faut bien sir créer une police (File > New), puis régler les préférences (Menu Tools-Options)

=) General Options EPS and bitmap background
Open and Save
Folders and paths EPS import:

EPS and bitmap background 5 ) Keep size (1 EPS pt = 1 UPM unit)

&= Font window (3) Fit between Ascender and Descender )

Glyph cell - n
&- Glyph window () Fit between Ascender and Baseline
Dimensions
Colors Bitmap height for the Create Bitmap command: [ 200 }

Metrics window
Opening Type 1
[=)- Opening OpenType & TrueType
TrueTypefOpenType TT (.ttf)
Generating Type 1
[=)- Generating OpenType & TrueType
TrueType/OpenType TT (.ttf)
OpenType PS (.otf)
OpenType TT Encoding

E] [ QK ][ Cancel ][ Apply

...pour que les importations prennent bien toute la place de la lettre
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Copier coller la lettre d'lllustrator en Fontlab ou Typetool
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La lettre est alors mise en plein milieu de la fenétre

Attention, il est également possible de double-cliquer dans la fenétre de la lettre a importer, puis faire File > Import > Eps a condition d'avoir

exporté votre fichier illustrator en EPS. Mais copier coller la lettre en Typetool va infiniment plus vite!
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Apreés l'importation il faut placer la lettre correctement et la redimensionner avec I'outil free transform :

I
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Entourer la lettre, puis... agrandir ou diminuer (ne pas oublier d'enfoncer la touche majuscule pour garder les proportions)
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Et si la lettre présente une contreforme (espace blanc a l'intérieur, comme dans le Q ci-dessus) Elle risque de ne pas
s'afficher correctement, d'étre "opaque"

Contour  Glyph Tools ‘Window Help

Transform » I

(
«s*  Set PS Direction
Convert ’

| <)+ Set IT Direction
i ‘}3 Correct Connections .
: A Reverse All Paths

T T

ring === |hungarum| ogonck

+ -] rr
¥ Nodes at Extremes

arenleft|parenright azterizk | pluz

Aller dans le menu Contour>Paths> et déterminer une direction au caractére, choisir (en gros) PS direction sur Mac et TT direction sur PC.

Placement de la lettre

Jambage
supérieur
ascendante
Ligne de base
Descendante

ou jambage inférieur /
Eperon

il faut la déplacer manuellement sur la ligne de base (le 0 en pointillé) en laissant déborder un peu les formes courbes et franchement les

descendantes
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Voici la structure globale des lettres avec les valeurs pour un caractére standard

ASCONEE. o o R R A
Caps height

x-height -« . ... .

I
|
: /box \j :

I /
Baseline""'"‘—————‘(—‘—-'*—H———-—I"""I—--———wwr—-'l ............ 0

RSB

Descender

Ceci vaut pour un caractére a empattements comme ci-dessus mais peut étre radicalement différent pour les scriptes
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Il faut également déterminer un espacement de part et d'autre, cela peut étre fait quand on a placé toutes les lettres

Les lignes verticales doivent étre un peu séparées de la lettre, ne pas la coller comme ci-dessus.
Une action globale peut se faire sur toutes les lettres via Tools > Action > Metrics —> Set sidebearings (au moins 30)
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Dans le menu File > Font info on peut spécifier les dimensions de base des caracteéres

Font Info - Selus

[=)-Names and Copyright
Copyright information
Designer information
License information

[=- Yersion and Identification
Identification settings

[=)- Metrics and Dimensions
Key dimensions
TrueType-specific metrics

Encoding and Unicode

Most important font dimensions

Ascender: Descender:
Caps height: x height:

|:] Copy values to TrueType metrics

Italic angle: D Slant angle: D

Copy Slant angle to Italic angle
Slant is based on FontMatrix and works only in T1

Thickness:

[CJFont is monospaced
This option is synchronized with the Panose identification

Font BBox: (-33, -343) - (1031, 997)

Underline: | -100

©J=)

[ o

][ Cancel ][ Apply ]

"Ascender" correspond a la valeur qui dépasse la hauteur des capitales - en s'y ajoutant. Ces valeurs permettent un interlignage en

correspondance aux descendantes.
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Mais également le nom et certaines spécificités du caracteére

Font Info - Untitled @ ]

=) Names and Copyright
Copyright information
Designer information
License information

Yersion and Identification
Identification settings

1]

Basic set of font names

Family Name: [ Selus

l

Weight: \ Regular

vH4oo | CIFont s italic

width: | Normal

[JFont is bold
v|

Metrics and Dimensions
Key dimensions
TrueType-specific metrics
Encoding and Unicode

1

More Styles  »

Style Name: ’ Reqular| v‘ [ Build Style Name |
PS Font Name: \ Selus ‘

Full Mame: l Selus ‘

Menu Name: [ Selus }

FOMD Mame: [ Selus }

I OK ][ Cancel ][ Apply ]

Cliquer sur "Build Names" permet de remplir automatiquement ce qu'il faut, il reste a spécifier la graisse (weight) la largeur (width) et le style
(regular ou italique par exemple)

Il faut maintenant paramétrer les approches entre les caractéres

VA 45

Ceci a pour but de régulariser ou peaufiner les espaces entre les caracteres. Observez I'approche entre un V et un A majuscule, la barre du A
doit se rapprocher du V, regardez comme le j va sous le e ci-dessus.
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Allez dans le menu Windows>New metrics window

T TypeTool 3 - [Preview/Metrics - Biro Script]

m File Edit View Contowr Glyph Tools Window Help

-Bx
DEHF | 2R o (&
(=2 S A I B i S S S RO NS s e
Wl E-n B
33 3 339 33 400 339 33 3 470 424 207 3T 23 424 207 339 3T 33 23 339 3 313 416 446 ksl 23 33 3T 630 33 489

fj /é; @')ng 70,/;0,/%( ZSZZ c()f/z; 0’{%/001/5 [Z l«/é;é
.

[ Kerning  w ][ Size: 72 v ]@@[ Options v ][ Tools = ”Ie texte qui suit est copié depuis le web ) ,V,lm

Du texte bidon est utilisé ici pour examiner les approches entre les lettres: on le sélectionne depuis le petit carré avec des points de suspension

en bas a droite de la fenétre ; on peut y coller du texte pris par exemple sur internet, avec une nette préférence pour du texte en francais vu que
les paires de lettres seront différentes.

On commence par un réglage automatique des approches (kerning)

Open Metrics...
[ Kerning  w ][ Size: 72 v ]@@| Options v l 5ave Metrics. .. n fox jumps over the lazy dog
Auto...
de A dohb = eset Kerning...

Depuis le menu Options
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En prenant les réglages ci-dessous :

Automatic Kerning Generation @

‘You want to generate kerning for: AII pairs in the Following list v ‘

Pairs list: | Standard v ‘

How much white space do you want to leave between glyphs?

v ‘ Custom:

When do you want to keep existing kerning?
|Never v|[10 %

[Medium

[ allow fFor positive kerning

Maximum number of pairs to generate: | 1024
Smallest allowable kern {absolute value):

[ ok

][ Cancel ]

Puis il faut peaufiner en prenant du texte en francais et en corrigeant les problémes au fur et a mesure

74

-

cafi-/ 2

On clique sur la lettre, dans ce cas-ci le i qui était trop loin du p ; cela fait apparaitre une réglette avec le réglage d'approche que TypeTool a
donné lors de I'approche automatique. On ramene la réglette et donc la lettre plus pres de la lettre qui la précede, ou éventuellement on

I'éloigne...
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Vient le temps du test, menu Tools > Quick Test as

I Test Font E]

v-ﬂ"ﬂﬂ v| % [Content ~]
ABCDEFGHI)KLMNOPRRSTUY /XY
Zaécy/é 4/)-4/;!4&0/07/‘S{MVL\/X>’Z_

Les lettres manquantes doivent bien sir étre corrigées (assez souvent il s'agit d'un probleme de contour mal réglé qui peut étre corrigé en
sélectionnant la lettre fautive et en faisant la commande Contour > Correct Open Contour)
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Aprés le réglage des approches et le test, on crée la police : File>Generate font, on prend Truetype TT sur pc et Opentype
PS sur mac.

Generate Font @

Enreaistrer dans : ‘ @ Bureau v | @ ? - '
r DMes documents
§ E, ﬂ Poste de travail
Mes documents gFavoris réseau
récents () Adobe Captivate 4
— [0 Adobe Captivate v4,0[h33t][Dave3737]
(£ ) TypeTool 3 for Windows
Bureau
Mes documents
Poste de travail
Q MNom du fichier : IBiro_ScriptZ v ! [, Enregistrer ,]
Favoris iéseau | Type: &ll Font Files v [ Annuler ]
All Font Files
Font name: [ el ype/Up pE
OpenType PS [*.atf)
Show Font preview  [win Type 1 [*pfb)
ASCIUnix Type 1 [*.pfa)
No font selected FontLab [*.vfb)
| Options I([:I Install the Font J

On peut cocher "install the font" et la tester!
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Sous Windows il faut impérativement sélectionner le réglage ci-dessous depuis le bouton Options

General Options Generating OpenType TT/TrueType encoding E]
Open and Save
Folders and paths Use following codepage to build cmap(1,0) table:

EPS and bitmap background M5 Windows 1252 Western (ANSI) |v

[=- Font window
Glyph cell

Glyph window
Dimensions
Colors

Metrics window

Opening Type 1

Opening OpenType & TrueType
TrueTypefOpenType TT (.ttf)

Generating Type 1

Generating OpenType & TrueType
TrueTypefOpenType TT (.ttf)
OpenType PS {.otf)

@ I OK I[ Cancel ][ Apply ]

[

1]

1]

1}

Sur Mac on prend le correspondant...
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